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GETTING STARTED 1

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . A S S E M B L Y  P C R  O L I G O  M A K E R

Assembly PCR Oligo Maker has been created to automate the design 
of oligodeoxynucleotides for the PCR-based construction of long DNA molecules. 
This application is designed specifically to aid in the design of DNA molecules 
that are to be used for the production of RNA molecules by in vitro synthesis with 
T7 RNA polymerase.

The input for Assembly PCR Oligo Maker is either the desired DNA sequence 
to be made or an RNA sequence. If RNA is the input, the program first determines 
the DNA sequence necessary to produce the desired RNA molecule. The program 
then determines the sequences of all the oligodeoxynucleotides necessary for 
a two-step assembly, PCR-based synthesis of the desired DNA molecule.

The output oligodeoxynucleotide sequences are designed to have a uniform melting 
temperature and are checked for regions of overlap outside of the desired priming 
regions necessary for the PCR.

Assembly PCR Oligo Maker has several advantages over similar applications that are 
currently available. These advantages are in addition to the ability of Assembly PCR 
Oligo Maker to handle RNA as an input and add the top17 sequence to determine 
the DNA sequence needed for RNA production. While this is a trivial process, 
the use of Assembly PCR Oligo Maker does remove the human element from this 
task, which can inadvertently introduce sequence errors into the final product.

The major advantage of using Assembly PCR Oligo Maker is that you have the option 
of determining the maximum length of oligodeoxynucleotides for assembly PCR that 
are created by the program. This option is not available in the other programs. 
You thus have the option of choosing to create fewer but longer 
oligodeoxynucleotides than determined by other programs. Working with fewer 
oligodeoxynucleotides means that the process of dissolving and diluting them 
and setting up the assembly PCR reaction is simplified and that fewer opportunities 
for human error are available during the experiment.

Finally, the output of Assembly PCR Oligo Maker is very clear; it lists the 
oligodeoxynucleotides needed for the assembly PCR reaction and the two 
oligodeoxynucleotides needed for the second PCR reaction as well as providing 
Assembly PCR Oligo Maker 1-1
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.G E T T I N G  S T A R T E D
Target audience
the predicted melting temperature values. All the oligodeoxynucleotides in the output 
are listed 5’ to 3’, which is a form that is suitable for cutting and pasting the sequences 
into an email or a web form for ordering oligodeoxynucleotides from the vendor 
of your choice.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . T A R G E T  A U D I E N C E

The intended audience of this user manual is any person wishing to synthesize 
a DNA template or an RNA product for research purposes and wants to simplify 
the work by using a computer application such as Assembly PCR Oligo Maker. 
Assembly PCR Oligo Maker is freely available at 
http://publish.yorku.ca/~pjohnson/AssemblyPCRoligomaker.html. It is assumed 
you have prior knowledge of biology and DNA.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . P O L Y M E R A S E  C H A I N  R E A C T I O N ,  P C R

The construction of long DNA oligonucleotides, such as synthetic genes, is useful for 
a number of reasons. For protein expression it is possible to improve the yield 
of a desired protein by optimizing codon usage to reflect the relative codon 
abundance in the host organism used for protein production. Additionally, 
oligodeoxynucleotides can be used to produce large amounts of RNA for structural 
or biochemical studies by in vitro transcription methods. Many RNA molecules 
studied to date are under 100 nucleotides in length, and the DNA oligonucleotides 
needed for their production are readily synthesized and are commercially available 
(up to 100-150 nucleotides long). As larger RNA molecules are studied, 
and if methods such as the use of cis3’ and/or 5’ ribozymes to facilitate RNA 
production or RNA-based affinity tags to aid in RNA purification are used, it is not 
possible to purchase DNA oligonucleotides of sufficient length to encode the desired 
RNA product. To produce these long DNA molecules (over 120-150 nucleotides), 
it is necessary to use techniques originally developed for gene synthesis, such as 
assembly PCR.

The polymerase chain reaction (PCR) is a commonly used method to amplify DNA 
sequences. PCR methods can be used to construct a synthetic gene through the use 
of a two-step PCR method referred to as assembly PCR (Figure 1).
Assembly PCR Oligo Maker 1-2
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.G E T T I N G  S T A R T E D
Polymerase chain reaction, PCR
Figure 1. The assembly PCR method for constructing long DNA molecules. (a) In the first PCR step a pool 
of oligodeoxynucleotides anneal and are (b) elongated to produce a full-length DNA molecule. In addition 
to the full-length product, a host of shorter molecules also results. (c) In the second PCR step the desired 
full-length molecule is selectively amplified from the mixture using primers specific for the desired product.

In the first step of assembly PCR, multiple oligodeoxynucleotides that contain 
overlapping regions anneal, and the DNA polymerase extends the primers and fills 
in the regions between the primers. A range of products of different lengths results 
from the different possible annealing combinations that involve less than all 
the oligodeoxynucleotides. In the second PCR step, a pair of primers that is specific 
for the full-length oligodeoxynucleotide is introduced and the full-length product 
is selectively amplified from the mixture.
Assembly PCR Oligo Maker 1-3
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.G E T T I N G  S T A R T E D
System requirements
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . S Y S T E M  R E Q U I R E M E N T S

Assembly PCR Oligo Maker is a Java Applet version 1.1.

It is compatible and has been tested with a variety of browsers (Netscape, IE, Mozilla 
Firefox, etc.) on different platforms (Microsoft Windows, Linux, and Mac) 
and should not require any Java plug-ins. However, if you have difficulty running 
the program, you should download the latest Java Runtime Environment (JRE) 
available for your platform from Sun Microsystems at http://java.sun.com.

Mac users be aware! It is inherent to Mac OS that all menus appear at the top 
of the screen. The 'File' and the 'Help' menus for the Assembly PCR Oligo Maker 
are therefore found at the top of the screen, as shown on the screenshot below 
in Figure 2, instead of being located above the application window.

Figure 2. A Mac OS screenshot of Assembly PCR Oligo Maker depicting the location of the menu.
Assembly PCR Oligo Maker 1-4
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.G E T T I N G  S T A R T E D
Interface overview
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . I N T E R F A C E  O V E R V I E W

Assembly PCR Oligo Maker’s interface is simple and composed of the input 
and the output, as shown in Figure 3. The input has only two choices: the type 
of DNA template or RNA product, and the order of the input 5’-…-3’ or 3’-…-’5.

For the output, DNA sequence, assembly oligos, flanking primers, the assembly 
melting temperature, and flanking primer melting temperatures will be displayed once 
the green, Determine Oligos button is pressed.

Figure 3. The Assembly PCR Oligo Maker’s interface.
Assembly PCR Oligo Maker 1-5
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.G E T T I N G  S T A R T E D
Clearing fields
Figure 4 shows the File menu, which includes Clear all fields, Customize, Show all results, 
and Exit.

Clear all fields: Clears all textboxes, and resets all radio buttons to default.
Customize: Allows the user to customize Assembly PCR Oligo Maker.
Show all results: Displays all results in a text box, so you can copy and paste them 

into another application.
Exit: Closes the program, and returns to the web browser.

Figure 4. The Assembly PCR Oligo Maker’s interface depicting the File menu.

Figure 5 shows the Help menu, which includes Help and About. 

Help: Displays help.
About: Shows the information about the version of the program 

and its authors.

Figure 5. The Assembly PCR Oligo Maker’s interface depicting the Help menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . C L E A R I N G  F I E L D S

This option resets all radio buttons to default values and clears all textboxes of input 
and output. You should use this option when you want to erase all previous input 
and output in order to avoid confusion.

1 Click File > Clear all fields.
Assembly PCR Oligo Maker 1-6
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Customizing Assembly PCR Oligo Maker
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . C U S T O M I Z I N G  A S S E M B L Y  P C R  O L I G O  M A K E R

Whenever you want to design oligodeoxynucleotides outside normal PCR conditions, 
you should use this option to input your reaction conditions. You can customize 
Assembly PCR Oligo Maker in the following ways:

• select the acceptable melting temperature for overlapping
• select the assembly (annealing) temperature
• select the maximum oligonucleotide length
• select the melting temperature method to be used in its calculations
• select the output in group of 3 nucleotides.
The window that allows you to customize Assembly PCR Oligo Maker is shown 
in Figure 6.

1 Click File > Customize.

Figure 6. Assembly PCR Oligo Maker’s customize dialog box.
Assembly PCR Oligo Maker 1-7
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.G E T T I N G  S T A R T E D
Customizing Assembly PCR Oligo Maker
Acceptable  melt i ng temperature for  over lappi ng

To ensure the success of assembly PCR, it is necessary that the oligodeoxynucleotides 
only anneal where desired. If an oligodeoxynucleotides can anneal in multiple ways, 
in either an intramolecular or intermolecular fashion, the subsequent PCR reactions 
would produce a host of undesired products. The Assembly PCR Oligo Maker 
program tests the oligodeoxynucleotides calculated for both PCR reactions for 
regions of overlap outside of the desired location. If a stretch of nucleotides is found 
to overlap at a region outside of the desired site, the program calculates a Tm value 
for this region of overlap. If the Tm value of the overlapping region detected is greater 
than the defined Tm threshold, a warning appears, notifying you that an undesired 
overlapping region was detected. The region is also flagged in the results window. 
You can then make changes to the sequence of the desired PCR product or ignore 
this warning and go ahead and attempt the PCR reaction despite the presence 
of an unwanted overlap region. Alternately, upon detection of an undesired region 
of overlap, you can choose to calculate oligodeoxynucleotides with a smaller or 
greater maximum length in order to try to break up the region of unwanted overlap.

Choose the acceptable melting temperature for overlapping between 
the oligonucleotides, the primers, and the duplex. Allowable input is an integer 
between 30 and 45°C inclusive. The default value is 40°C.

2 Type an integer between 30 and 45 inclusive. The program will not accept 

values outside this range and will display an error.

Assembly  (anneal ing)  temperature

Choose the assembly temperature during which the PCR reaction will occur. 
For optimal results, the PCR reaction must be performed between 50 and 60°C 
inclusive. The default value is 55°C.

2 Type in an integer between 50 and 60 inclusive. The program will not 

accept values outside this range and will display an error.

Maximum ol igonucleot ide length ca lculated

Choose the length of the oligonucleotides to be calculated. The default value is 70. 
When you choose a smaller nucleotide length, more nucleotides will be obtained.

2 Choose from 40, 50, 60, or 70 nucleotides in length. 
Assembly PCR Oligo Maker 1-8
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.G E T T I N G  S T A R T E D
Getting help
Melt ing temperature  method to  be used

Choose this method for melting temperature calculations.

2 Choose either the Basic or the Nearest Neighbour method. The formulae 

for each method used are shown below.

Basic: Tm(°C) = 2(A + T) + 4(G + C)
Nearest neighbour: Tm(°C) = (1000∆H°/∆S°+Rln([DNA]/4)) - 273.15

Nearest neighbour:

3 Type the monovalent cation concentration, a value between 0 and 10 M. 

The default value is 50.0 nM. Also, type in the DNA concentration, a value 

between 0 and 1 M. The default value is 0.5 mM.

Output  in  groups  of  3  nucleot ides

Choose whether to display the nucleotides in groups of 3’s separated by a space.

2 Check the Output in Groups of 3 Nucleotides checkbox to display 

the nucleotides in groups of 3’s. If you don’t check this box, the output 

oligos will not be separated by a space every 3 nucleotides.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . G E T T I N G  H E L P

This option displays a non-searchable text version of this manual. 

1 Click Help > Help again to open the help window, as shown in Figure 7.

Figure 7. The Help window.
Assembly PCR Oligo Maker 1-9
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Viewing credits
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . V I E W I N G  C R E D I T S

This option shows the information about the version of the program and its authors.

1 Click Help > About to display the credits window, as shown in Figure 8.

Figure 8. The About window.
Assembly PCR Oligo Maker 1-10
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MAKING OLIGOS 2

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . C A L C U L A T I N G  A N  R N A  P R O D U C T

The simplest use of the program is to determine the DNA sequence needed 
to produce a particular RNA molecule. First, the program determines the target DNA 
sequence to be produced, and then it computes the necessary oligodeoxynucleotides 
for both steps of the two-step assembly PCR synthesis method. By default, 
the program only determines assembly oligodeoxynucleotide sequences for DNA 
targets longer than 40 nucleotides.

The program works by dividing the target DNA into an even number of segments 
with a user-defined maximum length.

To customize your program before determining oligos, see section Customizing PCR 
Oligo Maker in chapter 2.

1 Select RNA product in the input section of the program.

2 Select the order, 5’-…-3’ or 3’-…-5’, of your RNA product.

3 Type or copy and paste the input into the input textbox. Allowable input 

for an RNA product is as follow:

• ‘c’ or ‘C’ for cytidine

• ‘a’ or ‘A’ for adenosine

• ‘g’ or ’G’ for guanosine

• ‘u’ or ‘U’ for uridine.

Nucleotides can be separated by spaces.

4 Click the Determine Oligos button.

5 Choose Yes if you want to add the Top17 sequence 

5'-TATAGTGAGTCGTATTA-3' to the beginning of your DNA sequence. 

No does not add the Top17 sequence.

DNA sequence, assembly oligos, flanking primers, assembly melting 

temperature, and flanking melting temperature will be displayed in their 

appropriate boxes. Any warnings or errors will be displayed with popup 

boxes. Refer to the Error section to find the meaning of an error message.
Assembly PCR Oligo Maker 2-11
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Calculating a DNA template
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . C A L C U L A T I N G  A  D N A  T E M P L A T E

You can also use the program to synthesize a DNA template. Assembly PCR Oligo 
Maker computes the necessary oligodeoxynucleotides for both steps of the two-step 
assembly PCR synthesis method. By default, the program only determines assembly 
oligodeoxynucleotide sequences for DNA targets longer than 40 nucleotides.

The program works by dividing the target DNA into an even number of segments 
with a user-defined maximum length.

To customize your program before determining oligos, see section Customizing PCR 
Oligo Maker in chapter 2.

1 Select DNA template in the input section of the program.

2 Select the order, 5’-…-3’ or 3’-…-5’, of you DNA template.

3 Type or copy and paste the input into the input textbox. Allowable input 

for an DNA template is as follow:

• ‘c’ or ‘C’ for cytidine

• ‘a’ or ‘A’ for adenosine

• ‘g’ or ’G’ for guanosine

• ‘t’ or ‘T’ for thymidine. 

Nucleotides can be separated by spaces.

4 Click the Determine Oligos button.

5 Choose Yes if you want to add the Top17 sequence 

5'-TATAGTGAGTCGTATTA-3' to the beginning of your DNA sequence. 

No does not add the Top17 sequence.

Assembly oligos, flanking primers, assembly melting temperature, and 

flanking melting temperature will be displayed in their appropriate boxes. 

Any warnings or errors will be displayed with popup boxes. Refer to the Error 

section to find the meaning of an error message.
Assembly PCR Oligo Maker 2-12
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Saving results
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . S A V I N G  R E S U L T S

You may want to save the results obtained during a calculation. All the results 
obtained in the output section of the program are shown in a textbox for you to copy 
and paste into your favourite application. Also, a visual representation of assembly 
oligos is shown at the bottom of the window, as shown in Figure 1.

Figure 1. Assembly PCR Oligo Maker window displaying all the results in one single textbox. Also, a visual 
representation of assembly oligos beneath.
Assembly PCR Oligo Maker 2-13



. . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
ERROR MESSAGES 3

A N  O L I G O  H A S  A  C O R R E S P O N D I N G ,  

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . M A T C H I N G  S E Q U E N C E  W I T H I N  I T S E L F

During oligo determination, if the program finds a region in one oligo that could 
possibly anneal to a region in the same oligo, this could be troublesome during a PCR 
reaction. To correct this situation, reduce the acceptable melting temperature 
for overlapping, or reduce the maximum oligonucleotide length calculated. Refer 
to the Customizing Assembly PCR Oligo Maker section in chapter 1 for more 
information. The error window is shown in Figure 1.

Figure 1. The Error window.

A  P R I M E R  H A S  A  C O R R E S P O N D I N G ,  

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . M A T C H I N G  S E Q U E N C E  W I T H  A  D U P L E X

During oligo determination, if the program finds a region in one oligo that could 
possibly anneal to a region in the duplex, this could be troublesome during a PCR 
reaction. To correct this situation, reduce the acceptable melting temperature 
for overlapping or reduce the maximum oligonucleotide length calculated. Refer 
to the Customizing Assembly PCR Oligo Maker section in chapter 1 for more 
information. The error window is shown in Figure 2.
Assembly PCR Oligo Maker 3-14
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A primer has a corresponding, matching sequence with the other primer
Figure 2. The Error window.

A  P R I M E R  H A S  A  C O R R E S P O N D I N G ,  
M A T C H I N G  S E Q U E N C E  W I T H  T H E  O T H E R  

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . P R I M E R

During oligo determination, if the program finds a region in one primer that could 
possibly anneal to a region in another primer, this could be troublesome during a PCR 
reaction. To correct this situation, reduce the acceptable melting temperature 
for overlapping or reduce the maximum oligonucleotide length calculated. Refer 
to the Customizing Assembly PCR Oligo Maker section in chapter 1 for more 
information. The error window is shown in Figure 3.

Figure 3. The Error window.
Assembly PCR Oligo Maker 3-15
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Invalid DNA template Invalid nucleotide in ( )
I N V A L I D  D N A  T E M P L A T E  I N V A L I D  

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . N U C L E O T I D E  I N  (  )

Enter a DNA template. Valid nucleotides are ‘c’ or ‘C’ for cytidine, ‘a’ or ‘A’ for 
adenosine, ‘g’ or ’G’ for guanosine, and ‘t’ or ‘T’ for thymidine. Nucleotides 
can be separated by spaces. The error window is shown in Figure 4. The invalid 
nucleotide will be placed in parenthesis, as shown in Figure 5.

Figure 4. The Error window.

Figure 5. Figure displaying an invalid nucleotide W, which is placed between parenthesis.

I N V A L I D  R N A  P R O D U C T  I N V A L I D  

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . N U C L E O T I D E  I N  (  )

Enter a valid nucleotide for an RNA product. Valid nucleotides are ‘c’ or ‘C’ for 
cytidine, ‘a’ or ‘A’ for adenosine, ‘g’ or ’G’ for guanosine, and ‘u’ or ‘U’ for uridine. 
Nucleotides can be separated by spaces. The error window is shown in Figure 4. 
The invalid nucleotide will be placed in parenthesis, as shown in Figure 5.
Assembly PCR Oligo Maker 3-16
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Some oligo has a corresponding, matching sequence in another oligo
S O M E  O L I G O  H A S  A  C O R R E S P O N D I N G ,  

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . M A T C H I N G  S E Q U E N C E  I N  A N O T H E R  O L I G O

During oligo determination, if the program finds a region in one oligo that could 
possibly anneal to a region in another oligo, this could be troublesome during a PCR 
reaction. To correct this situation, reduce the acceptable melting temperature for 
overlapping or reduce the maximum oligonucleotide length calculated. Refer 
to the Customizing Assembly PCR Oligo Maker section in chapter 1 for more 
information. The error window is shown in Figure 6.

Figure 6. The Error window.

T H E  D N A  T E M P L A T E  M U S T  B E  L O N G E R  T H A N  
4 0  N U C L E O T I D E S  I N  O R D E R  T O  C A L C U L A T E  

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . O L I G O S

Enter a DNA template that is at least 40 nucleotides long. Since there is no point 
in determining oligos for such a short DNA template, the program’s algorithm 
will not accept such a short input.

T H E  R N A  P R O D U C T  M U S T  B E  L O N G E R  T H A N  
4 0  N U C L E O T I D E S  I N  O R D E R  T O  C A L C U L A T E  

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . O L I G O S

Enter an RNA product that is at least 40 nucleotides long. Since there is no point 
determining oligos for a such short RNA product, the program’s algorithm will not 
accept such a short input.
Assembly PCR Oligo Maker 3-17
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